IDE Netbeans para aplicações Cordova/Phonegap/Ionic?

Vídeo mostra exatamente o funcionamento da IDE Netbeans usada para desenvolvimento de aplicativos com Cordova/Phonegap/Ionic. O vídeo mostra somente criação e edição de Ionic apps mas os 3 são muito semelhantes pois são derivados do cordova.

Quer testar e criar sua primeira app com cordova , ionic, phonegap?

Até a próxima!

Anúncios

Improve your English! IDE Netbeans em Inglês!

Aproveitando para melhorar o seu inglês todos os dias, é interessante que você use todas as suas ferramentas em inglês para realmente aplicar a “imersão na língua”. Troque a linguagem do seu smartphone, TV, tablet, Netbeans e tudo o que puder trocar pra te forçar a usar o inglês.

Indo ao tema do post, para trocar a linguagem da IDE há várias formas mas vou somente tratar de uma rápida aqui que muitos já conhecem pois os aplicativos java funcionam basicamente da mesma forma. O locale é especificação da língua e região que rodará o aplicativo e trocaremos ele na inicialização do netbeans da seguinte forma:

Feche o Netbeans, edite o arquivo <netbeans-dir>/etc/netbeans.conf  adicionando no parâmetro netbeans_default_options mais uma opção: –locale en_US e salve-o. Abra  o netbeans novamente e curta a versão original do netbeans! 🙂

Existem outras formas de realizar esta modificação mas esta é a forma que funcionará em qualquer Sistema Operacional.

Tem muito mais para modificar na inicialização. Dá uma olhada nestes links:

http://wiki.netbeans.org/FaqCustomLaf (aparência look and feel)

http://wiki.netbeans.org/FaqStartupParameters (outras modificações)

Até a próxima pessoal!

Erros no console ao atualizar iReport de versões anteriores para a iReport 5.6.0

Olá pessoal,

Tive que migrar o meu projeto para um novo notebook que fui obrigado a comprar por que o meu deu falência múltipla de ogãos. kkkk

Nesta mudança de hardware, já instalei versão nova de Netbeans para 8.0.2 e estou usando também o jdk8.

Rodei minha aplicação desenvolvida no Netbeans anterior e funcionou tudo legal, inclusive os relatórios.

Quando fui criar novos relatórios e dar manutenção nos já existentes no meu , instalei o iReport para 5.6.0 com o seu devido plugin instalado no netbeans e crirei o relatório normalmente.

Quando fui rodar, mensagem de erro no console. Começaram os problemas!

java.lang.NoClassDefFoundError: Could not initialize class net.sf.jasperreports.engine.util.JRStyledTextParser

Uma pesquisa rápida em um post de um desenvolvedor java no site guj, estava informando um problema semelhante e a solução que ele mesmo encontrou foi atualizar a biblioteca joda-time-2.1.jar que tinha a classe atualizada do JRStyledTextParser.

Opa, compilei novamente a aplicação e…. dai deu a mensagem:

at net.sf.jasperreports.engine.fill.JRBaseFiller.<init>(JRBaseFiller.java:124)

Para resolver definitivamente todos os problemas com bibliotecas deste meu projeto a solução foi atualizar todas as bibliotecas do meu projeto copiando as bibliotecas do iReport 5.6.0 localizadas em C:\Program Files (x86)\Jaspersoft\iReport-5.6.0\ireport\modules\ext (no windows) para dentro do seu projeto no netbeans e claro, não esquecer de atualizar as bibliotecas no projeto do netbeans no menu arquivo/propriedades do projeto/ bibliotecas.

Aos meus alunos: isso já aconteceu muitas vezes nos projetos de vocês em sala e corrigimos da mesma maneira. Vocês já estão experts nisso. 🙂

Até a próxima pessoal.

Projeto PHP 1sem2014

Conforme combinado com os alunos da Etec Piraju, segue projeto de PHP usado em sala de aula.

O projeto foi uma explicação de comandos básicos, formulários, funções isset, empty, require_once e realizando operações básicas com PHP. Este projeto foi desenvolvido no NetBeans.

Baixe-o aqui.

Até a próxima.

Projeto Java com Conexão MySQL 1sem2014

Conforme combinado com os alunos da Etec Piraju, segue projeto de java usado em sala de aula.

 

O projeto utiliza:

Netbeans, MVC, OO, JDBC e Banco de Dados MySQL.

Baixe-o aqui.

 

Até a próxima.

 

 

Invalid jdkhome specified – Netbeans

Na IDE Netbeans, esta mensagem pode aparecer na seguinte situação: você instala uma versão mais atualizada do jdk e desinstala a anterior sem ter configurado o Netbeans. Desta forma a IDE não encontra o jdk anterior e nos exibe esta crítica. A IDE tem um arquivo de configuração que armazena a jdk atualmente utilizada e que no momento da desinstalação da jdk anterior não foi setada/atualizada. Para resolver o problema, entre na pasta etc dentro do diretório de instalação do seu netbeans:

C:\Arquivos de programas\NetBeans 6.8\etc

Dentro desta pasta há um arquivo chamado netbeans.conf.

C:\Arquivos de programas\NetBeans 6.8\etc\netbeans.conf

Abra-o com o seu editor preferencial para editá-lo.

Na linha 19 você encontra a uma instrução semelhante a esta:

netbeans_jdkhome=”C:\Arquivos de programas\Java\jdk1.6.0_20″

Atualize a linha para a versão do jdk que você está utilizando p.e.:

netbeans_jdkhome=”C:\Arquivos de programas\Java\jdk1.6.0_21″

Neste arquivo também há outras informações de inicialização do netbeans como a pasta de trabalho do usuário e outros parametros de inicialização da IDE.

Quando você atualizar a jdk é importante conferir também as variáveis de ambiente CLASSPATH, JAVA_HOME e PATH.

Até a próxima.

Netbeans 6.9 lançado!

Baixe a nova versão do Netbeans 6.9 fresquinha e com novos recursos como JavaFX composer, JavaFX SDK 1.3, PHP Zend framework, and Ruby on Rails 3.0.

Leia abaixo sobre as melhorias.

Obs.: Este anúncio foi recebido através do cadastro no momento do download. Se quiser recebê-lo preencha com seu e-mail no momento do download. Se quiser fazer o download, clique na imagem abaixo.

NetBeans IDE 6.9 - The Smart Way to Code!

NetBeans™ IDE 6.9 introduces the JavaFX Composer, a visual layout tool for building JavaFX GUI applications, similar to the Swing GUI builder for Java SE applications. With the JavaFX Composer, developers can quickly build, visually edit, and debug Rich Internet Applications (RIA) and bind components to various data sources, including Web services.

The NetBeans 6.9 release also features OSGi interoperability for NetBeans Platform applications and support for developing OSGi bundles with Maven. With support for OSGi and Swing standards, the NetBeans Platform now supports the standard UI toolkit and the standard module system, providing a unique combination of standards for modular, rich-client development.

Additional noteworthy features in this release include support for JavaFX SDK 1.3, PHP Zend framework, and Ruby on Rails 3.0; as well as improvements to the Java Editor, Java Debugger, issue tracking, and more.

NetBeans IDE 6.9 is available in English, Brazilian Portuguese, Japanese and Simplified Chinese.

Download NetBeans IDE 6.9